[kforge-user] Authentication not working

Gunnar Johansson info at gunnar-johansson.se
Mon Sep 10 08:52:10 BST 2007


6 sep 2007 kl. 17.38 skrev Rufus Pollock:
> Gunnar Johansson wrote:
>> Hi all,
>> Sorry, I was too quick in my earlier post..
>> So, initially I had trouble authenticating when trying to access   
>> project services. Then I "hatched" the python egg for kforge  
>> which  solved that problem. But now authentication only works if I  
>> log in  through the kforge web interface - that is, not when I  
>> access a  service directly..  For example, accessing a svn rep.  
>> through the  terminal (svn co ...) doesn't work for me.  The  
>> apache error log just  says "user gunjo not found".
>> Anyone else had this problem?
>> I'm setting up a dedicated machine acting as a project server, so  
>> I'm  willing to try any linux distro as long as it works fine  
>> with  kforge.. Which system have you been developing and testing  
>> on?  I  currently used Ubuntu 6.06.
>
> Ok, I've managed to reproduce this on an Ubuntu machine so it is a  
> bug and its caused by the use of this line in the autogenerated  
> Apache config file:
>
>    AuthUserFile /dev/null
>
> Ironically this was specifically added to get auth working under  
> Apache 2.2 (and does work under Apache 2.2) but obviously causes  
> problems with Apache 2.0 (which is what Ubuntu 6.06 'dapper' uses).

To keeps things as smooth as possible I stepped up to ubuntu 7.04  
with a clean server install using the LAMP choice:

Apache/2.2.3 (Ubuntu) DAV/2 SVN/1.4.3 mod_python/3.2.10 Python/2.5.1  
PHP/5.2.1 mod_ssl/2.2.3 OpenSSL/0.9.8c

To benefit from the latest bugfixes I installed kforge from trunk  
which worked pretty smoothly except from some missing packages which  
were taken care of using apt-get.

I still had to hatch the kforge egg to get authentication working.

Also, I need to log in through the kforge interface - if I try to  
access a (trac) service directly I get a "Forbidden" message without  
any password dialog. I'm still happy it works by entering through  
kforge first though..!  Accessing svn through the terminal works fine  
- is the problem maybe trac specific?

What's the status on the www and dav services?  They are not enabled  
by default, and I don't really know how to enable them through the  
kforge-admin shell (since the admin web interface is currently down).  
What are the commands to enable them?

Regards,  Gunnar J

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.okfn.org/pipermail/kforge-user/attachments/20070910/87dd55a1/attachment.htm 


More information about the kforge-user mailing list