[kforge-user] kforge-0.13 installation issues

Gunnar Johansson info at gunnar-johansson.se
Thu Sep 6 15:29:22 BST 2007


Hi,

I'm in the process of setting up kforge on a clean Ubuntu  
installation and had the same problem as described in this thread. I  
would just like to confirm that "hatching" the kforge egg worked for  
me.  Although I did a standard installation of kforge by:

sudo easy_install kforge

Regards / Gunnar Johansson

21 aug 2007 kl. 17.22 skrev John Bywater:

> Tristan, Rufus,
>
>>>> OK, that's weird because it implies mod-python couldn't import
>>>> kforge.
>>>> Does importing kforge from a python shell work i.e.:
>>>>
>>>> $ python
>>>>>>> import kforge
>>>
>>> yes it does.
>>> And i can even use kforge web frontend. Service creation, user
>>> management, etc all work well. Except for the authentication  
>>> handler.
>
> ...
>
> EITHER
> Break the egg open (its just a zip file of the source). Then 'imp'  
> has a
> directory named after the package, and mod_python can import the  
> kforge
> package.
>
> OR
> Don't do this:
> $ python setup.py install --home=/my/local/folder
> $ python setup.py install --prefix=/my/local/folder
> Do this (or make sure your system does this):
> # python setup.py install
>
>
> If you're stuck I suggest breaking the KForge and DomainModel eggs  
> open,
> and seeing whether it just works. You may need to break Routes open  
> too
> if it was installed along with DomainModel.
>
> Best wishes,
>
> John.
>
>
>
>
> _______________________________________________
> kforge-user mailing list
> kforge-user at lists.okfn.org
> http://lists.okfn.org/mailman/listinfo/kforge-user

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.okfn.org/pipermail/kforge-user/attachments/20070906/4afe2867/attachment.htm 


More information about the kforge-user mailing list