[annotator-dev] Lost in the "current" Annotator 1.2.9 - looking a "state-of-the-art" plugin

Randall Leeds tilgovi at hypothes.is
Wed Jun 25 21:02:50 UTC 2014


On Wed, Jun 25, 2014 at 3:55 AM, Ernesto Torresin (ML) <
ewk-ml at connettivo.net> wrote:

> On 24/06/2014 16:01, Ernesto Torresin (ML) wrote:
> > On 24/06/2014 14:38, Ernesto Torresin (ML) wrote:
> >> On 24/06/2014 13:39, Ernesto Torresin (ML) wrote:
> >>> On 24/06/2014 12:18, Ernesto Torresin (ML) wrote:
> >>>> On 24/06/2014 11:00, Nick Stenning wrote:
> >>>>>
> >>> [...]
> >>>> I am using the master branch indeed, because to read the sources and
> >>>> compile I was requested by the Makefile to have a .git repository. I'm
> >>>> going for the 1.2.x branch now.
> >>>
> >>> 'npm install .' in the v1.2.x gave me coffescript at 1.6.3 as specified
> in
> >>> package.json and required by coffeebarx at 0.0.3, but Makefile wants to
> >>> call the coffeescript node module with the "--no-header" option, that
> >>> was not present in coffeescript before v. 1.7.1 if I understand
> >>> correctly
> >>>
> https://github.com/jashkenas/coffeescript/commit/2b03fa9077cea31b25cb23518d8af59fe5b80fed
> .
> >>> Should I modify the package.json or the Makefile?
> >>>
> >>
> >> No way in either way. Requesting a more recent coffeescript module
> >> breaks some dependencies, and removing the "--no-header" option just
> >> lets me hit against sed errors about missing files. BTW I get the same
> >> sed errors about missing files if I try to compile the version at
> >> https://github.com/openannotation/annotator/archive/v1.2.9.tar.gz
> linked
> >> to at https://github.com/openannotation/annotator/releases/tag/v1.2.9.
> >> I am installing npm modules locally in every version, and I can compile
> >> the clone of the master branch as usual.
> >>
> >> Any idea?
> >
> > OK, I don't need minified files to study the code, so I stripped away
> > the pkg/Makefile rules for the min.js files and now the
> > https://github.com/openannotation/annotator/archive/v1.2.9.tar.gz
> > compiles. This sounds like a reasonable start. I'm dropping the v1.2.x
> > branch because I'd like to start with something that was considered
> > stable enough for being released.
>
>
> Samll update: to get rid of the fatal git error about
> GIT_DISCOVERY_ACROSS_FILESYSTEM just run make in v1.2.9 as:
>
>         $ export VERSION=1.2.9; make
>
>
Sorry, what fatal error are you talking about?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.okfn.org/pipermail/annotator-dev/attachments/20140625/e06302a8/attachment-0002.html>


More information about the annotator-dev mailing list