[annotator-dev] jQuery minimum version

Benjamin Young bigbluehat at hypothes.is
Mon Jul 28 14:55:34 UTC 2014


Hey Greg,

Look's like the first commit that added `.addBack()` was in May to the 2.0
(`master`) development line:
https://github.com/openannotation/annotator/search?q=addBack

The `1.2.x` branch lacks those changes, and the last official release (of
1.2.9) was made in December 2013, so the docs are still correct.

2.0 docs will need the jQuery version updated...but there's likely more
changes to make to the docs for that. ;)

However, it seems that the `doc` directory only exists on `master`.

I'll add some issues about `doc` directory handling and we can go from
there.

Thanks for the report, Greg!
Benjamin


On Sun, Jul 27, 2014 at 7:24 PM, Greg Pendlebury <greg.pendlebury at gmail.com>
wrote:

> Just noticed in the doco:
> http://docs.annotatorjs.org/en/latest/getting-started.html
>
> "Annotator requires jQuery 1.6 or greater."
>
> But it uses .addBack():
> http://api.jquery.com/addback/
> "version added: 1.8 <http://api.jquery.com/category/version/1.8/>
> <http://api.jquery.com/addback/#addBack-selector>"
>
> Only thing I've seen so far (during upgrade from 1.2.6 => 1.2.9).
>
> Ta,
> Greg
>
> _______________________________________________
> annotator-dev mailing list
> annotator-dev at lists.okfn.org
> https://lists.okfn.org/mailman/listinfo/annotator-dev
> Unsubscribe: https://lists.okfn.org/mailman/options/annotator-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.okfn.org/pipermail/annotator-dev/attachments/20140728/aef8ea15/attachment-0002.html>


More information about the annotator-dev mailing list