[annotator-dev] Webkit changes, looks like it may break the annotator

Tom Rees zephod at gmail.com
Fri Jan 6 16:07:41 UTC 2012


Hi Ewald & Annotator-dev,
I've been seeing this message a lot lately -- it appears whenever JQuery is
loaded, and hopefully there's nothing specific to Annotator's code causing
the problem. Upgrading to JQuery 1.7 has solved the problem for me on
several projects with no changes to the codebase required. So it should be
a simple fix but not an urgent one yet.
Tom

On Thu, Jan 5, 2012 at 2:57 PM, Ewald Zietsman <ewald at siyavula.com> wrote:

> My Chrome upgraded in the last day or two and now when I load the
> annotator I get the following in the console:
>
> event.layerX and event.layerY are broken and deprecated in WebKit.
> They will be removed from the engine in the near future.
>
> Is there a fix or workaround for this?
>
> --
> Ewald Zietsman
>
> Technical Coordinator
>
>
>
> Website: www.siyavula.com
> The Open Innovation Studio, 27 Buitenkant Street, Cape Town, 8001
>
> A Shuttleworth Foundation Seeded Project
> Website: www.shuttleworthfoundation.org
>
> _______________________________________________
> annotator-dev mailing list
> annotator-dev at lists.okfn.org
> http://lists.okfn.org/mailman/listinfo/annotator-dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.okfn.org/pipermail/annotator-dev/attachments/20120106/b82cda7d/attachment-0002.html>


More information about the annotator-dev mailing list