[wdmmg-dev] wdmmgext namespace packages
friedrich.lindenberg at okfn.org
Sun Mar 20 11:12:24 GMT 2011
On Sat, Mar 19, 2011 at 8:04 PM, Rufus Pollock <rufus.pollock at okfn.org> wrote:
> On 19 March 2011 16:14, Friedrich Lindenberg
> <friedrich.lindenberg at okfn.org> wrote:
>> Hey Carsten,
>> thanks for pointing this out!
>> On Fri, Mar 18, 2011 at 11:38 AM, Carsten Senger <senger at rehfisch.de> wrote:
>>> Is it ok to
>>> * add a declare_namespace() call to wdmmg-ext/wdmmgext/__init__.py and
>>> * move wdmmg-ext/wdmmg/tests into wdmmg-ext/wdmmgext/load/tests
>> I think in fact it may make more sense to rename wdmmg-ext into
>> wdmmgext-load since that would reflect its purpose a lot better - what
>> do you think?
> -1 :) - could do other stuff in that repo and renaming is always
> costly (don't see great benefit here ...)
Benefit would be clarity: we have wdmmg-datatables and it makes
tables, wdmmg-bergen which takes care of a specific "customer" and we
already keep 90% of the current code in wdmmgext/load. I'm not
proposing we shut down the "misc bucket" wdmmg-ext, but that at this
stage having a cleanly named wdmmg-loaders would make things more
understandable. Not religious on this, though.
More information about the openspending-dev